Taxonomie et i18n

Bonjour,

J'ai constaté la présence de ce qui semble être des bugs dans l'utilisation de la taxonomie avec le module i18n.

J'ai créé un article qui les décrit précisément :

http://dev.le-temps-du-soi.com/fr/node/32

Comme je débute sur Drupal j'aurai voulu savoir s'il s'agit d'erreurs de configurations de ma part, ou si les même constats ont été fait.

Ceci afin de savoir si il vaut mieux que je bénéficie de quelques conseils éclairés ;) ou si je dois plonger dans le code et engager le débbugage maintenant.

Pour info je travail avec la 4.7.1

Merci.

Forum : 

i18n est un module essentiel (selon moi), mais il ne bénéficie malheureusement pas d'une large base d'utilisateurs et donc de l'attention qu'il mérite. Les bugs que tu soulèves proviennent de la transition vers la version 4.7 du module, qui est visiblement encore largement en friche.

J'ai rapidement regardé les problèmes que tu soulève, ils n'ont pas l'air trop difficile à corriger. En particulier le fait que le champ select ne s'affiche pas correctement à l'ouverture d'un "terme" (bug 1) est lié au fait que le code tente de charger la langue du vocabulaire parent au lieu de celle du terme courant (fichier i18n.inc aux lignes 125-130).

Je suis près à consacrer un peu de temps à la correction de ces bugs et à l'amélioration générale de ce module, si tu es prêt à accepter un petit coup de main.

  • DamZ

C'est Luis Reyero (son créateur) qui va être content si un autre dév lui apporte un coup de main.

Il y a de nombreux fils d'ouverts sur i18n et c'est effectivement largment en friche mais c'est un bon module. Module qui doit être paramétré avec soin... :-(
--
@+
sKanD

@+
sKanD - aka Stéphane

Bonjour,

J'utilise l'étiquetage libre de la taxonomie pour qu'une personne qui ajoute un contenu puisse ajouter en même temps les mots-clés qui s'y rapportent.

Cette fonctionnalité est intéressante et marche très bien sans le module i18n. Cependant lorsque celui-ci est installé, les nouveaux termes entrés dans l'étiquetage libre sont bien ajoutés au vocabulaire, mais ça ne les ajoute pas à l'article. Pour qu'ils soient ajoutés à l'article, il faut éditer le terme et juste soumettre (dans la taxonomie).

Y a-t-il un moyen d'éviter cette étape et de directement avoir les nouveaux termes affichés dans l'article?

Merci

Raphaël