[Résolu] PlanetHoster : connexion à la base de donnée... Je perd la tête !

Bonsoir,
J'ai souscrit à une offre de serveur mutualisé chez PlanetHoster.

J'aimerais installer Drupal en multi-site sur mon serveur.
J'essaye donc de suivre la démarche expliquée sur cette page : http://drupalfr.org/node/6171.
On me demande de ne pas utiliser l'installation via cPanel.

Le problème, c'est que je ne m'en sors pas :
- J'ai crée une base de donnée MySQL "monsite_drupal", vide ;
- J'ai crée un utilisateur avec toutes les permissions "monsite_user" associé au mot de passe "password" ;
- J'ai assigné à la bdd monsite_drupal l'utilisateur monsite_user.

Malheureusement, lorsque je lance l'installation de Drupal, à l'étape "Database configuration", lorsque je rentre :
- Database name: monsite_drupal ;
- Database username : monsite_user ;
- Database password : password ,
Drupal me répond

"Failed to connect to your MySQL database server. MySQL reports the following message: Access denied for user 'monsite_user'@'localhost' (using password: YES)."

C'est la catastrophe !
Alors, j'ai essayé d'installer via cPanel Drupal afin de voir comment il configurait automatiquement le fichier settingd.php. J'ai remarqué qu'il renseignait les deux lignes :

Je pense donc que je problème est que je ne lui renseigne pas la seconde ligne... Mais comment faire ?
D'autre part, est-ce normal qu'à l'entrée intitulée "Database password", je renseigne le mot de passe de l'utilisateur ?

Pouvez-vous me donner un coup de main ?
Merci d'avance,
Bonne soirée !

Version de Drupal : 

Bonjour,

Je pense que tu n'utilise pas les bons paramètres pour ta base de données.
Vérifie que ton login et mot de passe soyent correct.
Vérifie également auprès de ton hébergeur l'hote de la base. C'est en général localhost mais cela peut etre autre chose. Dans ce cas clique sur option avancé lors de l'installation et change database host pour ton hote.

Mickael

Salut !
Merci pour ta réponse ! Après trois jours de tourmente, j'ai compris :
le mot de passe que j'utilisais contenait le caractère "\"".

Je me suis rendu compte que lorsque j'entrais l'adresse MySQL comme URL, ce fameux caractère était remplacé par %22 ce qui m'a mis la puce à l'oreille.

Je reste pantois : suis-je donc le seul être humain qui utilise ce type de caractère dans mes mots de passe importants ? Pourquoi, en 2010, ce problème n'a-t-il pas été réglé ? Il y a des choses comme ça, en informatique et particulièrement sur Internet, qui laissent songeur. Je ne parle pas des acrobaties qu'il faut faire pour écrire des math...

Bref, merci pour ton aide mais mon problème est réglé : j'ai changé de mot de passe ! :)

Bonne journée !

Bonjour,

je viens moi-même de souscrire à une offre Performance (serveur mutualisé) sur PlanetHoster, et j'ai systématiquement un message d'erreur en mode administration "Got a packet bigger than 'max_allowed_packet' bytes query: UPDATE cache_menu ...".

La valeur par défaut de cette variable (Mysql) est de 1M; en Drupal 6, il est quasiment obligatoire de l'augmenter (16M min, cf requirements sur drupal.org); Or chez PlanetHoster cette variabla n'est apparemment pas configurable ! Comment faites-vous pour faire tourner un site Drupal6 chez PlanetHoster (leur support m'a proposé d'acheter une offre VPS !!) ?

Dois-je changer d'hébergeur?

Bon pour ceux qui tomberait dans le piège tendu par planethoster ! ...

Pour créer la base et surtout l'utilisateur, il ne faut pas passer par l'application MySql qui est dans le panel d'administration, mais par l'assistant.
Sinon, impossible de donner tous les droits a l'utilisateur et du coup on se retrouve confronté à l'erreur qui fait l'objet de ce post.